01-复杂度2 Maximum Subsequence Sum (25 分)

The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
(注意上方黑斜体部分,刚开始读题没看到…)
Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

我自己用的是最普通易理解的版本,注意的是

1:如果最大子列和小于0,max需要输出0,然后分别输出第一个和最后一个数。

代码如下:

#include <stdio.h>

int main()
{
    int n, i, j, a[10005], cu = 0, max, f = 0, l = 0, flag = 0;
    scanf("%d", &n);
    for (i = 1; i <= n; i++)
    {
        scanf("%d", &a[i]);
    }
    max = a[1];/*不能给max赋值为0,不然全是负数那个点就会错误*/
    for (i = 1; i <= n; i++)
    {
        cu = 0;

        for (j = i; j <= n; j++)
        {
            cu += a[j];
            if (cu > max)
            {
                max = cu;
            }
        }
    }
    for (i = 1; i <= n; i++)
    {
        f = a[i];
        cu = 0;
        for (j = i; j <= n; j++)
        {
            cu += a[j];
            if (cu == max)
            {
                l = a[j];
                flag = 1;
                break;
            }
        }
        if (flag)
        {
            break;
        }
    }
    if(max<0)
    {
        max = 0;
        f = a[1];
        l = a[n];
    }
    printf("%d %d %d", max, f, l);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

thoroughly strive

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值