PAT甲级A1108 Finding Average (20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

题意:给出n个数,让你求这n个数的平均数,注意这n个数可能存在非法数字,非法数字不计算在平均数内。当且仅当一个数字在[-1000,1000],且 最高保留两位小数才被认为是合法的,输出时注意区分合法数字是0,1,大于1这三种情况。

思路:首先判断数字是否合法,注意非法字符,小数点个数,以及小数位数,然后输出非法数字,最后统计平均数。

参考代码:

#include<cstdio>
#include<iostream>
#include<string>
#include<cmath>
#include<sstream>
using namespace std;
int n,num=0;		//num统计个数
double ans,t;	
int main()
{
	string s;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>s;
		int cnt=0,pos=0,flag=true;
		for(int j=0;j<s.size()&&flag;j++){
			if(!((s[j]>='0'&&s[j]<='9')||s[j]=='.'||(s[j]=='-'&&j==0)))
				flag=false;
			if(s[j]=='.') {		//统计小数点个数以及位置
				cnt++;
				pos=j;
			}
		}
		stringstream ss(s);    //使用字符串流把字符串转成浮点数
		ss>>t;
		if(!flag||cnt>1||abs(t)>1000||(cnt&&s.size()-1-pos>2)){	//数字超过1000或小数点存在且位数超过2位均非法
			cout<<"ERROR: "<<s<<" is not a legal number\n";
			 continue;
		}
		ans+=t;
		num++;
	}
	if(num==0) printf("The average of 0 numbers is Undefined\n");
	else if(num==1) printf("The average of 1 number is %.2f\n",ans);
	else printf("The average of %d numbers is %.2f\n",num,ans/num);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值