PAT-A1108/B1054 Finding Average/求平均值 题目内容及题解

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

解题思路

  1. 依次读入待检查字符串;
  2. 将其转化为数字或返回输入非法;
  3. 按题目要求格式输出结果并返回零值。

代码

#include<stdio.h>
#include<math.h>

double sum=0.0;
int cnt=0;
void check(){
    int i=0;
    int minus=1,dec=0,sum1=0,sum2=0;
    double ans=0.0;
    char temp[1000];
    scanf("%s",temp);
    if(temp[i]=='-'){
        minus=-1;
        i++;
    }
    while(temp[i]!=0){
        if(temp[i]>='0'&&temp[i]<='9'){//数字 
            if(dec==0){
                sum1=sum1*10+temp[i]-'0';
                if(sum1>1000){
                    break;
                } 
            }else{
                dec++;
                if(dec>3){
                    break;
                }
                sum2=sum2*10+temp[i]-'0';
            }
        }else if(temp[i]=='.'){//小数点 
            if(dec==0){
                dec++;
            }else{
                break;
            }
        }else{//其他 
            break;
        }
        i++;
    }
    if(temp[i]==0){
        ans=(sum1*1.0+((sum2*1.0)/pow(10.0,dec-1)));
        if(ans>1000){
            printf("ERROR: %s is not a legal number\n",temp);
            return;
        }
        ans*=(1.0*minus);
        sum+=ans;
        cnt++;
    }else{
        printf("ERROR: %s is not a legal number\n",temp);
    }
}

int main(){
    int N;
    scanf("%d",&N);
    while(N--){
        check();
    }
    if(cnt==0){
        printf("The average of 0 numbers is Undefined\n");
    }else if(cnt==1){
        printf("The average of 1 number is %.2lf\n",sum);
    }else{
        printf("The average of %d numbers is %.2lf\n",cnt,sum/cnt);
    }
    return 0;
} 

运行结果

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值