PAT甲级A1125 Chain the Ropes (25 分)

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10​4​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

题意:给出n个绳子,让你把这些绳子, 每两个系在一起对折拧成一股绳,重复此操作,直到只剩下一段绳子为止。让你求能得到的最大绳长。

思路:由于越早加入的绳子对折的次数越多,因此最终也就会越短,所以先把短的绳子加入,然后再放长的绳子,具体实现可以使用一个优先级队列(升序方式),每次取出较小的两个数,对折再放进去,直到只剩下一个数字为止。

参考代码:

#include<cstdio>
#include<queue>
using namespace std;
int n,t;
priority_queue<int,deque<int>,greater<int> > q;
int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&t);
		q.push(t);
	}
	while(q.size()>1){
		int a=q.top();q.pop();
		int b=q.top();q.pop();
		q.push((a+b)/2);
	}
	printf("%d\n",q.top());
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值