Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15
我的思路:
1. 建树,加一个变量level,开一个vector<int> v[1000], v[level]表示第level层的元素,一开始level为0,每一次level+1。
2. 之后之字形输出
#include <iostream>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
int n;
vector<int> inorder, postorder;
vector<int> v[10000];
void preBuild(int inl, int inr, int postRoot, int level){
if(inl > inr) return;
int i = inl;
while(inl < inr && postorder[postRoot] != inorder[i]) i++;
v[level].push_back(inorder[i]);
preBuild(inl, i-1, postRoot-1+i-inr,level+1);
preBuild(i+1,inr, postRoot-1, level+1);
}
int main(){
scanf("%d", &n);
inorder.resize(n), postorder.resize(n);
for(int i = 0; i < n; i++) scanf("%d", &inorder[i]);
for(int i = 0; i < n; i++) scanf("%d", &postorder[i]);
preBuild(0,n-1,n-1,0);
printf("%d", v[0][0]);
for (int i = 1; i < 35; i++){
if (i % 2 == 1){
for(int j = 0; j < v[i].size(); j++){
printf(" %d",v[i][j]);
}
}else{
for (int j = v[i].size()-1; j >= 0; j--){
printf(" %d",v[i][j]);
}
}
}
return 0;
}