【PAT甲级A1127】 ZigZagging on a Tree (30分)(c++)

1127 ZigZagging on a Tree (30分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

在这里插入图片描述

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题意:

将中序和后序排列二叉树创建二叉树,然后按照奇数层(根在层1)从右到左输出,偶数层从左往右输出。

思路:

创建好树以后,用dfs从左往右遍历树的结点,每经过一个点将其压如对应的层数,然后根据层数分奇偶输出。

参考代码:

#include <iostream>
#include <vector>

using namespace std;

struct Node {
    int val;
    Node *left, *right;
    Node(int v) : val(v), left(NULL), right(NULL) {}
};

int n, maxdepth = 0;
vector<int> in, post;
vector<vector<int>> level(30);

Node *creat(int posl, int posr, int inl, int inr) {
    if (posl > posr)return NULL;
    Node *root = new Node(post[posr]);
    int k;
    for (k = inl; k <= inr && in[k] != post[posr]; k++);
    int numleft = k - inl;
    root->left = creat(posl, posl + numleft - 1, inl, k - 1);
    root->right = creat(posl + numleft, posr - 1, k + 1, inr);
    return root;
}

void dfs(Node *root, int depth) {
    if (root == NULL)return;
    level[depth].push_back(root->val);
    dfs(root->left, depth + 1);
    dfs(root->right, depth + 1);
}

int main() {
    scanf("%d", &n);
    in.resize(n + 1);
    post.resize(n + 1);
    for (int i = 1; i <= n; i++)scanf("%d", &in[i]);
    for (int i = 1; i <= n; i++)scanf("%d", &post[i]);
    Node *root = creat(1, n, 1, n);
    dfs(root, 1);
    for (int i = 1; !level[i].empty(); i++) {
        if (i % 2 == 1) {
            for (int j = level[i].size() - 1; j >= 0; j--) {
                if (i != 1 || j != level[i].size() - 1)printf(" ");
                printf("%d", level[i][j]);
            }
        } else {
            for (int j = 0; j < level[i].size(); j++)
                printf(" %d", level[i][j]);
        }
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值