robot framework-Python2与Python3共存的情况

我之前写Appium的脚本用的是Python3

在学习robot framework的时候发现,很多人用的都是Python2

用过Python的都知道,Python3与Python2之间有语法不同,但是网上关于RF的教程大多数用py2(主要是公司其他同事用py2,so,基于个别问题,我还是得用py2)

不过用py3也可以,RF官方已经支持了py3,只是不能使用ride而已,到后期我觉得ride也没有什么太大作用,且有局限性

初期学习的话,还是先从py2开始了解吧,如果有耐心去读官方文档,可以直接从py3开始

那么在Python2和Python3共存的情况下,需要做哪些配置,如下:

1、下载Python2和Python3后

      在环境变量-系统变量-path中添加2和3的路径,这里用2举例,3同理:;D:\python27\Scripts\;D:\python27\;

2、分别将目录中的Python.exe修改,用2举例:D:python27目录下


然后在cmd中运行Python2,可以正常显示版本号


3、运行pip2或pip3

你可能会如下错误:

Fatal error in launcher: Unable to create process using '"'

那么解决办法是你需要分别运行如下命令:

python3:

python3 -m pip install --upgrade pip

python2:

python2 -m pip install --upgrade pip

然后再运行pip2和pip3就都正常了

4、接下来安装robot

分别用pip2和pip3安装,因为会安装到相应目录下,这里不多赘述

5、Python2需要安装wxPython

这里下载安装就行了http://sourceforge.net/projects/wxpython/files/wxPython/2.8.12.1/

6、Python2还要安装robotframework-ride

pip2 install robotframework-ride 就行了


-----------------------------2018.4.24更新补充------------------------------

若运行ride运行脚本时,出现如下错误:


将python2.exe改成python.exe,注意:必须是在环境变量确定已配好的情况下

阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页