Graph’s Cycle Component(并查集优化)

In graph theory, a cycle graph is an undirected graph that consists of a single cycle, or in other words, some number of vertices connected in a closed chain.
Now, you are given a graph where some vertices are connected to be components, can you figure out how many components are there in the graph and how many of those components are cycle graphs.

Two vertices belong to a same component if and only if those two vertices connect each other directly or indirectly.

input

The input consists of multiply test cases.
The first line of each test case contains two integer, n (0 < n < 100000), m (0 <= m <= 300000), which are the number of vertices and the number of edges.
The next m lines, each line consists of two integers, u, v, which means there is an edge between u and v.
You can assume that there is no multiply edges and no loops.
The last test case is followed by two zeros, which means the end of input.

output

For each test case, output the number of all the components and the number of components which are cycle graphs

sample input

8 9
0 1
1 3
2 3
0 2
4 5
5 7
6 7
4 6
4 7
2 1
0 1
0 0

sample output

2 1
1 0

题意就是找出无向图中有几个连通块,有几个环

解法还是并查集,但是环需要加一个标记数组来确定,具体的直接看代码吧。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int map[110000],in[110000];
int x,y,n,m,a,b;
int find(int x)
{
	 return map[x]==x?x:find(map[x]);
}
void merge(int a,int b)
{
    int p=find(a);
    int q=find(b);
    if(p<q)
        map[q]=p;
    else
        map[p]=q;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(m==0&&n==0)
        break;
		for(int i=1;i<=n;i++)
           map[i]=i;
        memset(in,0,sizeof(in));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&a,&b);
            a++;
			b++;
            in[a]++;
            in[b]++;
            merge(a,b);
        }
        x=0;
        y=0;
        for(int i=1;i<=n;i++)
            if(map[i]==i)
                x++;
        for(int i=1;i<=n;i++)
			if(in[i]!=2)
                map[find(i)]=0;
        for(int i=1;i<=n;i++)
            if(map[i]==i)
                y++;
        printf("%d %d\n",x,y);
    }
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值