In-circles Again (计算几何)

In the figure below you can see triangle ABC and its in-circle (Circle that touches all the sides of a triangle internally). The radius of this in circle is r. Three other circles are drawn. Each of them touches two sides of this triangle and the in circle of ABC. The radiuses of these circles are r1, r2 and r3.

Given the values of r, r1, r2 and r3 you will have to find the area of triangle ABC.

input

The input file can contain up to 1000 lines of inputs. Each line contains four positive floating-point numbers which denotes the values of r, r1, r2 and r3 respectively.

Input is terminated by a line containing four negative integers.


output

For each line of input produce one line of output. This line contains serial of output followed by a floating-point number which denotes the area of triangle ABC. This floating-point number may have two digits after the decimal point. You can assume that for the given values of r, r1, r2 and r3 it will always be possible to construct a triangle ABC. If required you can assume that pi = 3.141592653589793 and also use double precision floating-point numbers for floating-point calculations. You can assume that there will be no such input for which small precision errors will cause difference in printed output. Look at the output for sample input for details.


sample input

49.1958415692 5.3025839959 20.7869367050 31.8019699761
186.6830516757 71.9474500429 84.8796672233 37.6219288070
-1 -1 -1 -1

sample output

Case 1: 18237.14
Case 2: 195777.32

这是一道计算几何的问题,今天醒的特别早,大早上水了一题。

具体的细节看代码吧,其实就是一个数学的问题。


#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
	double r,r1,r2,r3;
	int count=1;
	while(scanf("%lf %lf %lf %lf",&r,&r1,&r2,&r3),r>=0&&r1>=0&&r2>=0&&r3>=0)
	{
		double x1,x2,x3,a,b,c,l,mian; 
		x1=r2*(r+r2)/(r-r2);
		x2=r3*(r3+r)/(r-r3);
		x3=r1*(r1+r)/(r-r1);
		x1=sqrt((x1+r2+r)*(x1+r2+r)-r*r);
		x2=sqrt((x2+r3+r)*(x2+r3+r)-r*r);
		x3=sqrt((x3+r1+r)*(x3+r1+r)-r*r);
		a=x1+x2;
		b=x2+x3;
		c=x1+x3;
		l=(a+b+c)/2;
		mian=sqrt(l*(l-a)*(l-b)*(l-c));
		printf("Case %d: %.2f\n",count++,mian);
	}
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值