Find them, Catch them POJ - 1703(带权并查集)

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up
the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify
 which gang a criminal belongs to. The present question is, given two criminals; do they belong
 to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at
 least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5)
 messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input:

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases.
 Then T cases follow. Each test case begins with a line with two integers N and M, followed by M
lines each containing one message as described above.


Output:

For each message "A [a] [b]" in each case, your program should give the judgment based on the information
 got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input:

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output:

Not sure yet.
In different gangs.
In the same gang.

思路:

开一个数组来记录每个点跟root的关系,典型的带权并查集。

代码:

#include<cstdio>  
#include<iostream> 
  
using namespace std;
  
int p[100005]; 
int r[100005];  
  
int Find(int a)
{  
    if(a == p[a])return a;  
  
    int t = p[a];   
    p[a] = Find(p[a]);  
    r[a] = (r[a]+r[t])%2;   
    return p[a];   
}  
  
void Union(int a, int b)  
{  
    int A = Find(a);   
    int B = Find(b);  
  
    p[A] = B;   
    r[A] = (r[a]+1+r[b])%2;  
}  
  
int main()  
{  
    int T;  
    int N,M;  
    cin>>T;  
    while(T--)  
    {     
  		cin>>N>>M;
		for(int i=1 ; i<=N ; i++){
			p[i] = i;
			r[i] = 0;
		}  
  
        while(M--)  
        {   
			char ch;  
	        int a,b;
	        getchar();
			scanf("%c %d %d",&ch,&a,&b);
            if(ch == 'A')  
            {  
            	if(Find(a) != Find(b))cout<<"Not sure yet."<<endl;
                else   
                {  
                    if(r[a] != r[b])cout<<"In different gangs."<<endl;  
                    else cout<<"In the same gang."<<endl;  
                }    
            }  
            else if(ch == 'D')  
            {  
                Union(a,b);  
            }  
        }  
    }  
    return 0;  
}  

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值