HDU 5676 ztr loves lucky numbers

ztr loves lucky numbers. Everybody knows that positive integers are lucky if their decimal representation doesn’t contain digits other than 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not.

Lucky number is super lucky if it’s decimal representation contains equal amount of digits 4 and 7. For example, numbers 47, 7744, 474477 are super lucky and 4, 744, 467 are not.

One day ztr came across a positive integer n. Help him to find the least super lucky number which is not less than n.
Input
There are T (1≤T≤10^5) cases

For each cases:

The only line contains a positive integer n(1≤n≤10^18) . This number doesn’t have leading zeroes.
Output
For each cases
Output the answer
Sample Input
2
4500
47
Sample Output
4747
47

思路:
可以用STL的next_permutation。不过我写的时候不会这个(尴尬),所以还是自己老老实实写吧。
先递归build一个记录了1到10^18的所有super lucky numbers的数组,之后只需要每次遍历就行了,
可以再加上二分法不过这里我没用也过了,数据不是很严,主要考的是这种类似桶排序的思路。

代码:

#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;

long long board[100000];
int flag;


void build(int a,int b,long long t){
    if(a == 0 && b == 0){
        board[flag++] = t;
        return ;
    }
    if(a!=0)build(a-1,b,t*10+4);
    if(b!=0)build(a,b-1,t*10+7);
    return;
}

int main(){
    int T;
    cin>>T;
    for(int i=1 ; i<=9 ; i++){
        build(i,i,0);
    }
    long long N;
    while(T--){
        scanf("%lld",&N);
        int i;
        for(i=0 ; i<flag ; i++){
            if(board[i]>=N){
                printf("%lld\n",board[i]);
                break;
            }
        }
        if(i == flag)printf("44444444447777777777\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值