hdu 5676 ztr loves lucky numbers

ztr loves lucky numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1112    Accepted Submission(s): 468


Problem Description
ztr loves lucky numbers. Everybody knows that positive integers are lucky if their decimal representation doesn't contain digits other than 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not.

Lucky number is super lucky if it's decimal representation contains equal amount of digits 4 and 7. For example, numbers 47, 7744, 474477 are super lucky and 4, 744, 467 are not.

One day ztr came across a positive integer n. Help him to find the least super lucky number which is not less than n.
 

Input
There are T (1n105)  cases

For each cases:

The only line contains a positive integer  n(1n1018) . This number doesn't have leading zeroes.
 

Output
For each cases
Output the answer
 

Sample Input
  
  
2 4500 47
 

Sample Output
  
  
4747 47
 

   首先找出所有的幸运数字,再进行查找

   例如47 74 4477 4747 4774 7447 7474 7744.........

  用dfs枚举即可,再存放在set中,用lower_bound查找第一个不小于输入数字的元素。

  当输入大于 777777777444444444时,满足条件的下一个幸运数超出long long 的范围,所以要特判。

#include <iostream>
#include <cstdio>
#include <set>
using namespace std;
typedef long long ll;
ll a[262220];
set<ll>b;
void dfs(ll x,ll y,ll cnt)
{
  if(x==0&&y==0)
  {
    b.insert(cnt);
    return;
  }
  if(x>0) dfs(x-1,y,cnt*10+4);
  if(y>0) dfs(x,y-1,cnt*10+7);
}
int main()
{
    int t;
    b.insert(47);
    b.insert(74);
    for(int i=2;i<=9;i++)
    {
      dfs(i,i,0);
    }
    scanf("%d",&t);
    ll n;
    while(t--)
    {
      scanf("%lld",&n);
      if(n>777777777444444444)
      {
        printf("44444444447777777777\n");
        continue;
      }
      printf("%lld\n",*b.lower_bound(n));
    }
    return 0;
}




 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值