2017杭电多校联赛 1011 KazaQ's Socks HDU 6043

KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are n−1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k
-th day.
Input
The input consists of multiple test cases. (about 2000)

For each case, there is a line contains two numbers n,k (2≤n≤109,1≤k≤1018)
.
Output
For each test case, output ” Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y
denotes the answer of corresponding case.
Sample Input

3 7
3 6
4 9

Sample Output

Case #1: 3
Case #2: 1
Case #3: 2

思路:
可以模拟过程,不过其实没必要,自己写写就很容易发现规律。
例如:n为3时 1 2 3 1 2 1 3 1 2 1 3…….
n为4时 1 2 3 4 1 2 3 1 2 4 1 2 3 1 2 4……
n为5时 1 2 3 4 5 1 2 3 4 1 2 3 5 1 2 3 4 1 2 3 5……
很明显一直是最后的两个数交替出现。
代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>

using namespace std;

int main(){
    long long N,K;
    int flag = 0;
    while(scanf("%lld %lld",&N,&K)!=EOF){
        printf("Case #%d: ",++flag);
        if(K<=N)printf("%d\n",K);
        else {
            K -= N;
            int t1 = K/(N-1);
            int t2 = K%(N-1);
            if(t1&1){
                if(t2 == 0)printf("%d\n",N-1);
                else if(t2 == N-1)printf("%d\n",N);
                else printf("%d\n",t2);
            }
            else {
                if(t2 == 0)printf("%d\n",N);
                else printf("%d\n",t2);
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值