POJ - 2689 Prime Distance 大区间素数筛选

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

题意:求给定区间内的相邻质数距离最小的一对和距离最大的一对。

思路:首先不可能直接求出1e9之间的所有质数,但是我们可以用sqrt(2147483647)内的质数筛出来, 给定区间长度少于1e6,所以直接用这些质数筛出来区间内的合数,剩下的自然是质数。

代码:

//#include <bits/stdc++.h>
#include <cstdio>
#include <cstring>

using namespace std;

const int MAXN = 1000005;
const int INF = 0x3f3f3f3f;

int prime[MAXN],M_P_factor[MAXN];//记录质数,记录每个数的最小质因子 
bool board[MAXN];

inline int pre_work(int n){
	int tot = 0;//质数的个数 
	for(int i=2 ; i<=n ; ++i){
		if(!M_P_factor[i]){
			M_P_factor[i] = i;
			prime[++tot] = i;
		}
		for(int j=1 ; j<=tot ; ++j){
			if(prime[j] > M_P_factor[i] || prime[j]*i > n)break;
			M_P_factor[i*prime[j]] = prime[j]; 
		}
	}
	return tot;
}

inline void init(){
	memset(prime,false,sizeof prime);
	memset(M_P_factor,0,sizeof M_P_factor);
}

int main(){
	
	init();
	int num = pre_work(50005);
	int L,U;
	while(scanf("%d %d",&L,&U) == 2){
		memset(board,false,sizeof board);
		for(int i=1 ; i<=num ; ++i){
			if(prime[i] >= U)break;
			long long fi = (L/prime[i])*prime[i];
			if(L%prime[i])fi += prime[i];
			for(long long j=fi ; j<=U ; j+=prime[i]){
				if(j!=prime[i]){
					if(!board[j-L])board[j-L] = true;
				}	
			}
		}
		if(L == 1)board[0] = true;//注意1要特殊处理
		int mi = INF,ma = 0,last = -1;
		int num1,num2,num3,num4;
		for(int i=0 ; i<=U-L ; ++i){
			if(board[i])continue;
			if(last == -1)last = i;
			else {
				int len = i - last;
				if(len < mi){
					mi = len;
					num1 = last;
					num2 = i;
				}
				if(len > ma){
					ma = len;
					num3 = last;
					num4 = i;
				}
				last = i;
			}
		}
		if(mi == INF && ma == 0)printf("There are no adjacent primes.\n");
		else printf("%d,%d are closest, %d,%d are most distant.\n",num1+L,num2+L,num3+L,num4+L);
	}
	
	return 0;
} 


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值