Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2 6 19 0
Sample Output
10 100100100100100100 111111111111111111
题目大意:找到n的一个只含有1 0的倍数
解题思路:对倍数dfs,有两条路径一个是*10 另一个是*10+1,注意不能爆范围
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int flag,n;
void dfs(unsigned __int64 x)
{
if(flag||x>9000000000000000000) return ;\\防爆范围
if(x%n==0){printf("%I64d\n",x);flag=1;}
dfs(x*10);
dfs(x*10+1);
}
int main(){
while(scanf("%d",&n)!=EOF&&n)
{
flag=0;
dfs(1);
}
return 0;
}