Wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题目大意:n组数据,每组m条正权边,w条负权边,给出m+w个边的起始点s终止点e和花费时间t,求是否可能在走完任意条边时可以使时间回到最开始之前

解题思路:想要回到最开始之前,就要使从出发点出发到回到出发点存在负权回路————bellman_ford算法了解一下(可以检测负权回路)

#include <iostream>
#include <queue>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
#include <cmath>
#define inf 0x3f3f3f3f
using namespace std;
int T,n,m,w,a,b;
int u[10000],v[10000],t[10000];
bool bellman_ford()
{
    int i,j;
    int dis[1000];
    for(i=1; i<=n; i++)
    {
        dis[i]=inf;
    }
    dis[1]=0;
    for(i=1; i<=n-1; i++)
    {
        for(j=1; j<=m+w; j++)
        {
            if((dis[v[j]]>dis[u[j]]+t[j])&&j<=m)
            {
                dis[v[j]]=dis[u[j]]+t[j];
            }
            else if((dis[u[j]]>dis[v[j]]+t[j])&&j<=m)
            {
                dis[u[j]]=dis[v[j]]+t[j];
            }
            else if((dis[v[j]]>dis[u[j]]-t[j])&&j>m)
            {
                dis[v[j]]=dis[u[j]]-t[j];
            }
        }
    }
    for(j=1; j<=m+w; j++)
    {
        if((dis[v[j]]>dis[u[j]]+t[j])&&j<=m)
        {
            return 1;
        }
        else if((dis[u[j]]>dis[v[j]]+t[j])&&j<=m)
        {
            return 1;
        }
        else if((dis[v[j]]>dis[u[j]]-t[j])&&j>m)
        {
            return 1;
        }
    }
    return 0;
}
int main()
{
    int i;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d %d",&n,&m,&w);
        for(i=1; i<=m+w; i++)
        {
            scanf("%d %d %d",&u[i],&v[i],&t[i]);
        }
        if(bellman_ford())
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值