hdu 1016 Prime Ring Problem

题目链接

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33354    Accepted Submission(s): 14760


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

<span style="font-size:18px;color:#006600;background-color: rgb(255, 255, 255);">#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;

#define PI acos-1.0
#define N 30

int n, ans, flag, prime[N];
bool vis[N];
int isprime (int x, int y);
void DFS (int cur);

int main ()
{
    ans = 0;
    while (cin >> n)
    {
        ans++;
        flag = 0;
        memset (vis, false, sizeof (vis));
        prime[1] = 1;
        DFS (2);
        cout << endl;
    }
}

void DFS (int cur)
{
    vis[1] = true;
    if (cur > n && isprime (prime[1], prime[n]))
    {
        if (!flag)
        {
            cout << "Case " << ans << ':' << endl;
            flag = 1;
        }
        for (int i=1; i<n; i++)
            cout << prime[i] << ' ';
        cout << prime[n] << endl;
    }

    else
    {
        for (int i=2; i<=n; i++)
        {
            prime[cur] = i;
            if (!vis[i] && isprime (prime[cur], prime[cur-1]))
            {
                vis[i] = true;
                DFS (cur + 1);
                vis[i] = false;
            }
        }
    }
}

int isprime (int x, int y)
{
    int sum = x + y;
    for (int i=2; i<sum; i++)
        if (sum % i == 0)
            return 0;
    return 1;
}
</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_大太阳_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值