2015长春赛 Almost Sorted Array

http://acm.hdu.edu.cn/contests/contest_showproblem.php?cid=646&pid=1006

Almost Sorted Array

Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array  a1,a2,,an , is it almost sorted?
Input
The first line contains an integer  T  indicating the total number of test cases. Each test case starts with an integer  n  in one line, then one line with  n  integers  a1,a2,,an .

1T2000
2n105
1ai105
There are at most 20 test cases with  n>1000 .
Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
Sample Input
  
  
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
Sample Output
  
  
YES YES NO


数据范围比较大,所以不能用双重for循环

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;


#define N 240000
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-8
#define met(a, b) memset (a, b, sizeof (a))

const int dir[4][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};

typedef long long LL;

int a[N];

int main ()
{
    int t, n;
    scanf ("%d", &t);

    while (t--)
    {
        int flag = 0;

        scanf ("%d", &n);

        for (int i=0; i<n; i++)
            scanf ("%d", &a[i]);

        int p = 0, q = 0, Index = 1, cnt = 0;

        for (int i=1; i<n; i++)//判断上升序列
        {
            if (a[i] >= a[i-1])
                p++;
            else
            {
                Index = i;
                cnt++;
            }
        }

        if (p == n-1) flag = 1;

        if (cnt == 1)
        {
            if (Index == 1 || Index == n-1 || a[Index-1]<=a[Index+1] || a[Index-2]<=a[Index])
                flag = 1;
        }

        cnt = 0, Index = 1;
        for (int i=1; i<n; i++)//判断下降序列
        {
            if (a[i] <= a[i-1])
                q++;
            else
            {
                Index = i;
                cnt++;
            }
        }

        if (q == n-1) flag = 1;

        if (cnt == 1)
        {
            if (Index == 1 || Index == n-1 || a[Index-1]>=a[Index+1] || a[Index-2]>=a[Index])
                flag = 1;
        }

        if (flag) puts ("YES");
        else puts ("NO");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_大太阳_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值