迷宫问题

</pre>Description</p><div class="textBG"><div class="ptx" lang="en-US">定义一个二维数组: <pre>int maze[5][5] = {

 0, 1, 0, 0, 0,

 0, 1, 0, 1, 0,

 0, 0, 0, 0, 0,

 0, 1, 1, 1, 0,

 0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)

(4, 4)

#include <iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<stack>
#include<queue>
using namespace std;
stack <char> s;

queue<int> p;


int a[5][5];
int dx[4] = {1, 0, -1, 0};
int dy[4] = {0, 1, 0, -1};
int ans = 0;//记录第几步


struct node
{
    int x;
    int y;
}pad[25];
void dfs(int n, int m)
{

    for (int i = 0; i < 4; i++)
    {
        int nx = n + dx[i];
        int ny = m + dy[i];
        if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && a[nx][ny] == 0)
        {
            a[nx][ny] = 1;
            pad[ans].x = nx;
            pad[ans++].y = ny;
            if (nx == 4 && ny == 4)
            {
                for (int j = 0; j < ans; j++)
                {
                    printf("(%d, %d)\n", pad[j].x, pad[j].y);
                }
                return ;
            }
            else
              dfs(nx, ny);
            a[nx][ny] = 0;
            pad[--ans].x = 0;
            pad[ans].y = 0;
        }
    }

}
int main()
{
    for (int i = 0; i < 5; i++)
    {
        for (int j = 0; j < 5; j++)
        {
            scanf("%d", &a[i][j]);
        }
        getchar();
    }
    printf("(0, 0)\n");
    dfs(0, 0);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值