Prime Time (打表高精度)

该博客讨论了欧拉发现的一个公式,n^2 + n + 41,在0到40范围内产生质数。虽然这个公式不总是产生质数,但在n ≤ 10,000,000时,它产生了47.5%的质数。程序旨在计算给定区间内由该公式产生的质数比例,并提供了示例输入和输出。" 50838320,5621569,Zabbix 2.4.6 客户端安装教程:Windows & Linux,"['Zabbix', '服务器监控', '系统管理', 'Windows', 'Linux']
摘要由CSDN通过智能技术生成

Euler is a well-known matematician, and, among many other things, he discovered that the formula
n
2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41.
Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known
that for n ≤ 10000000, there are 47,5% of primes produced by the formula!
So, you’ll write a program that will output how many primes does the formula output for a certain
interval.
Input
Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must
read until the end of the file.
Output
For each pair a, b read, you must output the percentage of prime numbers produced by the formula in
this interval (a ≤ n ≤ b) rounded to two decimal digits.
Sample Input
0 39
0 40
39 40
Sample Output
100.00
97.56
50.00
求输入所给范围内的数经过题目要求的变化后的数的素数百分比.
#include<stdio.h>
#include<math.h>
#include<string.h>
using namespace std;
int hh[10010]= {1};//素数打表
void dabiao()
{
for(int i=1; i<10010; i++)
{
int flag=0;
int t=i*i+i+41;
for(int j=2; j<=sqrt(t); j++)
{
if(t%j0)
{
flag=1;
}
}
if(flag
0)
hh[i]=1;
}
for(int i=0; i<=10000; i++)
{
hh[i]=hh[i]+hh[i-1];
}
}
int main()
{
int a,b;
dabiao();
while(scanf("%d%d",&a,&b)!=EOF)
{
double x=hh[b]-hh[a-1];
printf("%.2lf\n",x/(b-a+1)*100.0+1e-8);//精度问题,需要注意!
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值