抓牛

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

一.队列

C++队列Queue类成员函数如下:

back()返回最后一个元素

empty()如果队列空则返回真

front()返回第一个元素

pop()删除第一个元素

push()在末尾加入一个元素

size()返回队列中元素的个数

queue 的基本操作举例如下:

       queue入队,如例:q.push(x); 将x 接到队列的末端。

queue出队,如例:q.pop(); 弹出队列的第一个元素,注意,并不会返回被弹出元素的值。

访问queue队首元素,如例:q.front(),即最早被压入队列的元素。

访问queue队尾元素,如例:q.back(),即最后被压入队列的元素。

判断queue队列空,如例:q.empty(),当队列空时,返回true。

访问队列中的元素个数,如例:q.size(—)

二.关于广搜步骤

从谁开始就把谁存到队列里,从它开始进行以后的步骤,广搜的话会遇到许多分支一类的东西,每遇到一个分支就要push进队列里,每次处理判断时都要处理最前边的,即front(),处理的同时也要将其删掉pop(),方便可以一直处理front()的那个。在处理的过程中也要判断找寻是否是结果,进行判断。。。。进行广搜要灵活将struct与queue结合使用,化繁为简。

广搜适用于最短最小问题,先搜到的路径一定是最小的。

三。广搜例题(一)

  catch that cow

一个数轴,一个人只能朝前走一步或者朝后走一步,或者走到现在位置的2倍,问抓到母牛的最小步数,假设牛不动。

思路:用struct储存人走到的位置,和人走到此地的步数。搜的时候加一减一乘二。走过的地点进行标记,重复走无意义。

原文链接:https://blog.csdn.net/xianpingping/article/details/76595916

 

   #include <stdio.h>

   #include <string.h>

   #include <queue>

   using namespace std;

   const int N = 1000000;

   int map[N+10];

   int n,k;

   struct node

   {

   int xx,step;

   };

    int check(int xx)

   {

     if(xx<0 || xx>=N || map[xx])

  return 0;

return 1;

}

int bfs(int xx)

{

int i;

queue<node> Q;

node a,next;

a.xx = xx;

a.step = 0;

map[xx] = 1;

Q.push(a);

while(!Q.empty())

{

a = Q.front();

Q.pop();

if(a.xx == k)

return a.step;

next = a;

next.xx = a.xx+1;

if(check(next.xx))

{

next.step = a.step+1;

map[next.xx] = 1;

Q.push(next);

}

next.xx = a.xx-1;

if(check(next.xx))

{

next.step = a.step+1;

map[next.xx] = 1;

Q.push(next);

}

next.xx = a.xx*2;

if(check(next.xx))

{

next.step = a.step+1;

map[next.xx] = 1;

Q.push(next);

}

}

return -1;

}

int main()

{

int sum;

while(~scanf("%d%d",&n,&k))

{

memset(map,0,sizeof(map));

sum = bfs(n);

printf("%d\n",sum);

}

return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值