定理:每一个大于1的正整数n都可以唯一地写成素数的乘积,在乘积中的素因子按照非降序排列,正整数n的分解式n=(p1^α1)*(p2^α2)*(p3^α3)* ....... *(pk^αk)称为n的标准分解式,其中p1,p2,p3......pk是素数,p1<p2<p3.....,且α1,α2,α3.......是正整数。
性质:(1)设d(n)为n的正因子的个数,则有d(n)=(α1+1)*(α2+1)*(α3+1)*......*(αk+1)
//p1可以取0~α1个,有α1+1种取法,同理p2有α2+1种取法
(2)设f(n)为n的所有因子之和,则有f(n)=【(p1^α1)-1】/(p1-1) * 【(p2^α2)-1】/(p2-1) * ..... *【(pk^αk)-1】/(pk-1)
(3)n! 的素因子分解中的素数p的指数(幂)为【n/p】+【n/p^2】+【n/p^3】+.......
应用1:输入正整数n,计算 n! 中末尾0的个数
输入:输入一个正整数n (1≤n≤1 000 000 000)
输出:输出 n! 末尾0的个数
样例输入:3
100
1024
样例输出:0
24
253
分析:求n的阶乘末尾0的个数,即求n的阶乘的素因子分解中有多少对(2,5),即求2的指数和5的指数,取其中小的个数(利用性质3可求)
代码:
#include <cstdio>
#include <iostream>
using namespace std;
int main()
{
int n;
int s1,s2;
int two,five;
while(scanf("%d",&n)!=EOF)
{
two=2;
s1=0;
while(two<=n)
{
s1+=n/two;
two<<=1;
}
five=5;
s2=0;
while(five<=n)
{
s2+=n/five;
five*=5;
}
printf("%d\n",min(s1,s2));
}
return 0;
}
补充:对于n!,在因式分解中,因子2的个数大于5的个数,所以如果存在一个因子5,那么它必然对应着n!末尾的一个0。(只求5的指数即可)
应用2:对于给定的素数p,C(2n,n)恰好被p整除多少次?
输入:输入n和p,(1≤n,p≤1 000 000 000)
输出:输出给出的C(2n,n)被素数p整除的次数,当不能整除时,次数为0。
样例输入:2 2
2 3
样例输出: 1
1
分析:ans=(【2n/p】-2【n/p】)+(【2n/p^2】-2【n/p^2】)+......... +(【2n/p^k】-2【n/p^k】) 其中k=log p(2n)向下取整
代码:
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main()
{
int n,p;
int ans,c,s;
while(scanf("%d%d",&n,&p)!=EOF)
{
s=int(log10(2.0*n)/log10(p));
c=1;
ans=0;
for(int i=1;i<=s;i++)
{
c*=p;
ans+=int(2*n/c)-2*int(n/c);
}
printf("%d\n",ans);
}
return 0;
}