ZOJ - 3981 - Balloon Robot

Balloon Robot

Time Limit: 1 Second       Memory Limit: 65536 KB

The 2017 China Collegiate Programming Contest Qinhuangdao Site is coming! There will be  teams participating in the contest, and the contest will be held on a huge round table with  seats numbered from 1 to  in clockwise order around it. The -th team will be seated on the -th seat.

BaoBao, an enthusiast for competitive programming, has made  predictions of the contest result before the contest. Each prediction is in the form of , which means the -th team solves a problem during the -th time unit.

As we know, when a team solves a problem, a balloon will be rewarded to that team. The participants will be unhappy if the balloons take almost centuries to come. If a team solves a problem during the -th time unit, and the balloon is sent to them during the -th time unit, then the unhappiness of the team will increase by . In order to give out balloons timely, the organizers of the contest have bought a balloon robot.

At the beginning of the contest (that is to say, at the beginning of the 1st time unit), the robot will be put on the -th seat and begin to move around the table. If the robot moves past a team which has won themselves some balloons after the robot's last visit, it will give all the balloons they deserve to the team. During each unit of time, the following events will happen in order:

  1. The robot moves to the next seat. That is to say, if the robot is currently on the -th () seat, it will move to the ()-th seat; If the robot is currently on the -th seat, it will move to the 1st seat.
  2. The participants solve some problems according to BaoBao's prediction.
  3. The robot gives out balloons to the team seated on its current position if needed.

BaoBao is interested in minimizing the total unhappiness of all the teams. Your task is to select the starting position  of the robot and calculate the minimum total unhappiness of all the teams according to BaoBao's predictions.

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains three integers  and  (), indicating the number of participating teams, the number of seats and the number of predictions.

The second line contains  integers  (, and  for all ), indicating the seat number of each team.

The following  lines each contains two integers  and  (), indicating that the -th team solves a problem at time  according to BaoBao's predictions.

It is guaranteed that neither the sum of  nor the sum of  over all test cases will exceed .

Output

For each test case output one integer, indicating the minimum total unhappiness of all the teams according to BaoBao's predictions.

Sample Input
4
2 3 3
1 2
1 1
2 1
1 4
2 3 5
1 2
1 1
2 1
1 2
1 3
1 4
3 7 5
3 5 7
1 5
2 1
3 3
1 5
2 5
2 100 2
1 51
1 500
2 1000
Sample Output
1
4
5
50
Hint

For the first sample test case, if we choose the starting position to be the 1st seat, the total unhappiness will be (3-1) + (1-1) + (6-4) = 4. If we choose the 2nd seat, the total unhappiness will be (2-1) + (3-1) + (5-4) = 4. If we choose the 3rd seat, the total unhappiness will be (1-1) + (2-1) + (4-4) = 1. So the answer is 1.

For the second sample test case, if we choose the starting position to be the 1st seat, the total unhappiness will be (3-1) + (1-1) + (3-2) + (3-3) + (6-4) = 5. If we choose the 2nd seat, the total unhappiness will be (2-1) + (3-1) + (2-2) + (5-3) + (5-4) = 6. If we choose the 3rd seat, the total unhappiness will be (1-1) + (2-1) + (4-2) + (4-3) + (4-4) = 4. So the answer is 4.


题意:

有n支队伍,m个座位围成一圈,其中有n个座位分别属于n支队伍,第i支队伍对应编号为si的座位。

整场比赛有p个通过,每个通过都有对应的队伍编号ai和通过时间bi,每个通过都要给对应队伍送一个气球

假设气球送到时间为ci,则该题的不满意值为ci-bi

现在有一个送气球机器人,机器人只能顺时针走,每一个时间走到下一位置,机器人开始位置在1-m之间

求最少的不满意值之和为多少


思路:

假设机器人的初始位置为 pos ,

则第i个通过的不满意值为 ( ( s[ a[i] ] - pos + m) % m - b[i] % m + m) % m

其中机器人到team a[i] 的时间为 s[ a[i] ] - pos + k*m


求一次和的时间复杂度为O(p)

如果还要遍历机器人位置求和的话总的时间复杂度就是O(p^2),所以不能直接遍历的写


考虑能不能求出一个然后其余的都用这个得到,减少每次求和的过程

将所有的不满意值(uhp)排序之后就可以得到一个关系,当以排序后的第i个位置为起始位置时,

当前不满意值之和 = cost - p * uhp[i] + i * m 

其中uhp为以位置pos作为起始位置的第i个不满意值 uhp[i] = ( ( s[ a[i] ] - pos + m) % m - b[i] % m + m) % m

其中cost为以位置pos作为起始位置的不满意值之和 cost = ∑uhp[i]




#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
#define LL long long
const int N = 1e5+10;
LL T,n,m,p;
LL s[N],uhp[N],cost,ans,a,b;
int main()
{
    scanf("%lld",&T);
    while(T--){
        cost = 0;
        scanf("%lld%lld%lld",&n,&m,&p);
        for(int i=1;i<=n;i++) scanf("%lld",&s[i]);
        for(int i=0;i<p;i++){
            scanf("%lld%lld",&a,&b);
            uhp[i] = ((s[a] - 1 + m)%m - b%m + m)%m;
            cost += uhp[i];
        }
        ans = cost;
        sort(uhp,uhp+p);
        for(int i=0;i<p;i++){
            ans = min(ans, cost-p*uhp[i]+i*m);
        }
        printf("%lld\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值