POJ 2437 Muddy Roads(贪心 最少固长线段覆盖区间)

Language:
Muddy roads
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3389 Accepted: 1557
Description

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools.

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely.

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.
Input

  • Line 1: Two space-separated integers: N and L

  • Lines 2..N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap.
    Output

  • Line 1: The miminum number of planks FJ needs to use.
    Sample Input

3 3
1 6
13 17
8 12
Sample Output

5
Hint

INPUT DETAILS:

FJ needs to use planks of length 3 to cover 3 mud pools. The mud pools cover regions 1 to 6, 8 to 12, and 13 to 17.

OUTPUT DETAILS:

FJ can cover the mud pools with five planks of length 3 in the following way:
111222..333444555….

               .MMMMM..MMMM.MMMM....

               012345678901234567890

Source

USACO 2005 U S Open Silver

题意:n个区间,给出每个区间的起始点,注意是左闭右开的,问最少用多少长为l的线段能覆盖掉这n个区间

做法:以每个区间的左端点排序,以tmp记录下当前覆盖区间的右端点(开),看下一个区间的端点和tmp的大小关系就好了
如b小于tmp就说明这个区间已经被覆盖了,b>=tmp 时, 再看a,如果a>tmp说明这个区间还有一部分没有被覆盖,把a赋值为tmp-1(因为a为闭,tmp是开)
a<=tmp时就重新计算一下区间需要用的线段更新最右端

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <stack>
#include <vector>
#define maxn 10010
#define maxe 100010
typedef long long ll;
using namespace std;
const double eps=1e-5;
const int inf=0x3f3f3f3f3f;
struct Node
{
    int a,b;
}node[maxn];
int cal(int a,int b,int l)
{
    if((b-a)%l==0)return (b-a)/l;
    else return (b-a)/l+1;
}
bool cmp(Node x,Node y)
{
    return x.a<y.a;
}
int main()
{
    int n,l;
   // freopen("in.txt","r",stdin);
    while(scanf("%d%d",&n,&l)==2)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&node[i].a,&node[i].b);
        }
        sort(node,node+n,cmp);
        int tmp=node[0].b;
        int ans=cal(node[0].a,node[0].b,l);
        int q=ans*l+node[0].a;
        int p=0;
        tmp=max(tmp,q+1);
        for(int i=1;i<n;i++)
        {
            if(node[i].b<tmp)continue;
            if(node[i].a<tmp)
            {
                node[i].a=tmp-1;
                p=cal(node[i].a,node[i].b,l);
                ans+=p;
                q=node[i].a+l*p+1;
                tmp=q;
            }
            else
            {
                p=cal(node[i].a,node[i].b,l);
                ans+=p;
                tmp=max(node[i].b,node[i].a+p*l+1);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值