Aggressive cows POJ - 2456

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input
* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
* Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9
Sample Output
3
题目大意:
用给定数量的牛放入所给的位置中,使得牛之间的位置间隔最大。。。
思路:
又是从一堆数中找出一个数,所以是用二分,然后就要找二分的对象啦,对象很明显就是间隔大小,这里需要注意的就是判断间隔是否符合要求的函数的写法,因为这道题是上课的例题,所以我用的是学长给的方法,详情请看代码;
下面是ac代码:
#include<cstdio>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
int n,m,a[100005];
int fuck(int x)
{
	int cnt=1,t=0;;
	for(int i=1;i<n;i++)
	{
		if(a[i]-a[t]<x)
			continue;
		t=i;
		cnt++;
	}
	if(cnt>=m)
		return 1;
	return 0;
}
int main()
{
	while(scanf("%d%d",&n,&m)==2&&n&&m)
	{
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		sort(a,a+n);
		int low=0,high=inf,mid;
		while(high-low>1)
		{
			mid=(low+high)/2;
			if(fuck(mid))
			low=mid;
			else
			high=mid;
		}
		printf("%d\n",low);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值