Crossing River

3 篇文章 0 订阅
A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.
Output
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input
1
4
1 2 5 10
Sample Output
17







题目大意:

有n个人想过河,但是他们只有一条能同时载两个人的船,每个人划船渡河的时间不同,当两个人同乘一艘船时,他们划船所用时间按较慢的人的速度计算。问你n个人全部过河所需的最短时间。要注意的是船划过河对岸再回来的时间也需要计算进去。


题目分析:

n=1;n=2;n=3的情况很好分析,当n=3时,渡河的时间刚好是三个人所用时间相加(最快最慢过去,t+=最慢,然后最快回来,t+=最快,然后最快次快过去,t+=次快)所以我们直接从n=4开始,假设他们按划船的速度从慢到快排列是ABCD四人,可以知道,船必须回来才能到达使全部人过去,而回来的人肯定要是已经过河的人中速度最快的那个,那么一去一回就变成了n=3的情况,第一次没有过去的两个人和过去了没返回的一个人时间算了一次,第一次去又返回了的那个人的时间算了两次,也就是说tmin=ta+tb+tc+td+min(a,b,c,d),这是基于两种策略来的

第一种:AB过去,A回来,CD过去,B回来,AB过去(T=B+A+D+B+B)

第二种:AD过去,A回来,AC过去,A回来,AB过去(T=D+A+C+A+B)

这两种策略的最后一步都是AB过去,所以我们可以知道,4个人在选取全局最优策略的前提下,局部问题要过去最慢的两个人所需的时间是2*B+D和A+C+D中的最小值。

这个结论可以继续向更大的n拓展(其实我也不知道为什么,我把我能理解的部分已经讲清楚了。。),所以当n>=4时,我们可以不断借助最快的两个人,让他们运送最慢的两个人过去,当n<4时就直接处理。


代码如下:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int T,n,m,i,p,q,sum;
	int a[1005];
	scanf("%d",&T);
	while(T--)
	{
		sum=0;
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		sort(a,a+n-1);
		while(n>=4)
		{
			p=2*a[0]+a[n-1]+a[n-2];
			q=a[0]+2*a[1]+a[n-1];
			if(p>q) sum+=q;//时间加上两种策略中较小的一个
			else sum+=p;
			n-=2;//最慢的两个人被运过去了
		}
		if(n==3)
			sum+=a[0]+a[1]+a[2];
		else if(n==2) sum+=a[1];
		else if(n==1) sum+=a[0];
		printf("%d\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值