c++1062-1066(5题)

1062: 练12.2奇葩的饭店

样例输入
100 1
样例输出
1.0000
#include<iostream>
using namespace std;
int main(){
    int a,b;
    cin>>a>>b;
    double r=0;
    r=1.0*b/a*100;
    printf("%.4lf",r);
    return 0;
}

1063: 练12.3 A×B问题

样例输入
3 4
样例输出
12
#include<iostream>
using namespace std;
int main(){
    long long n,x;
    cin>>n>>x;
    cout<<n*x<<endl;
    return 0;
}

1064: 练12.4计算并联电阻的阻值

样例输入
1 2
样例输出
0.67
#include<bits/stdc++.h>
using namespace std;
int main(){
    double r1,r2;
    cin>>r1>>r2;
    double R=1/(1/r1+1/r2);
    printf("%.2lf\n",R);
    return 0;
}

1065: 【例13.1】空格分隔输出

样例输入
a
12
2.3
3.2
样例输出
a 12 2.300000 3.200000
#include<iostream>
#include<stdio.h>
using namespace std;
int main(){
    int a;
    char b;
    float c;
    double d;
    scanf("%c%d%f%lf",&b,&a,&c,&d);
    printf("%c ",b);
    printf("%d ",a);
    printf("%.6f ",c);
    printf("%.6f ",d);
    return 0;
}

1066: 【例13.2】 电子表

样例输入
3701
样例输出
01:01:41
#include<bits/stdc++.h>
using namespace std;
int main(){
    int x;
    scanf("%d",&x);
    printf("%02d:%02d:%02d",x/3600,(x%3600)/60,x%60);
    return 0;
}

有什么问题可以私信我!!!

  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值