1010 Radix (25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tagis 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

  思路:二分搜索进制, n1 n2 比较时,先将n1转化为10进制,然后求 n2进制的范围。求出最小进制(string串中最大的字符对应的数字+1)和最大进制(最小进制和另一个待比较的数的10进制转化的结果 两个的最大值) 二分搜索进制,每次搜索后,比较大小,直到相等为止。( 数据范围用long long .  )

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
#define ll long long
using namespace std;
ll numsto10(string n1,int radix)
{
	int len=n1.length();
	ll res=0;
	for(int i=0;i<len;i++)
	{
	  if(isdigit(n1[i])) res=res*radix+n1[i]-'0';
	  else if(isalpha(n1[i])) res=res*radix+n1[i]-'a'+10;
	}
	return res;
}
ll findradix(string n1,ll num,ll low,ll high)
{
	ll mid;
    while(low<=high)
	{
	     mid=(low+high)/2;
		 ll tmp=numsto10(n1,mid);
		 if(tmp>num||tmp<0)
		 {
			 high=mid-1;
		 }
		 else if(tmp==num) return mid;
		 else low=mid+1;
	}
	return -1;
}
int main()
{
	string n1,n2;
	int tag,radix;
	cin>> n1 >>n2 >> tag >>radix;
    if(tag==2) swap(n1,n2);
	ll nums10=numsto10(n1,radix);
	ll low=0;
	for(int i=0;i<n2.length();i++)
	{
		if(isdigit(n2[i])) {if(n2[i]-'0'>low) low=n2[i]-'0'+1;}
		else if(isalpha(n2[i])){if(n2[i]-'a'+10>low) low=n2[i]-'a'+10+1;}
	}
	ll high=max(nums10,low);
	ll result=findradix(n2,nums10,low,high);
	if(result==-1)
		cout<<"Impossible"<<endl;
	else
		cout<<result<<endl;
	return 0;

}

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值