1094 The Largest Generation (25 分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

  思路: 求树中的一层,孩子数最多,用dfs深搜,然后用hashtable 记录每一层的节点数,关键点在这里,每一次dfs就需要进行一次记录,故需要把hasht 放在dfs的入口处

#include<bits/stdc++.h>
#define ll long long
using namespace std;
const int maxn=110;
vector<int> tree[maxn];
int n,m,hasht[maxn]={0},maxc=0;
void dfs(int root, int depth)
{
    hasht[depth]++;
    if(tree[root].size()==0) {
        return ;
    }
    for(int i=0;i<tree[root].size();i++)
    {
        dfs(tree[root][i],depth+1);
    }
}
int main()
{
    cin>>n>>m;
    int id,k,tmp;
    for(int i=0;i<m;i++)
    {
        cin>>id>>k;
        for(int i=0;i<k;i++)
        {
            cin>>tmp;
            tree[id].push_back(tmp);
        }
    }
    dfs(1,1);
    int cnt=0;
    for(int i=0;i<maxn;i++)
    {
        if(hasht[i]>maxc)
        {
            cnt=i;
            maxc=hasht[i];
        }
    }
    //cout<<hasht[1]<<endl;
    cout<<maxc<<" "<<cnt<<endl;
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值