联赛

Problem C

Time Limit: 2000/1000 MS (Java/Others)     Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 551    Accepted Submission(s): 83
Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.
 
Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)
 
Output
Output the maximum value in a single line for each test case.
 
SampleInput
5 20
go 5 8
think 3 7
big 7 4
read 2 6
write 3 5
 
SampleOutput
15

   
   
Hint
Input data is huge,please use “scanf(“%s”,s)”
 
//题意:一个人学习英语单词,每个单词都是不同的,
//并且都有自身的价值量 w 和难度值 c (0<=w,c<=10)
// 现在给定总单词个数 N 和可以总难度值 V,求最大的价值。
//刚开始做用01背包做 超时 感觉特别烦人 就耐不住了 看了一下别人的博客
//说 01背包转化成多重背包  自己感觉真的很菜 好好努力了
//因为ci和vi的取值很小,重复的次数很多 要进行存储压缩
//用1,2,4,…,2^k 将多重背包转化为0-1背包。 如13=1+2+4+6
#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
struct node
{
    int v,c;
}N[100010];
int f[10010];
int map[12][12];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int n,m,a,b,num;
    char st[20];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        num=0;
        memset(map,0,sizeof(map));
        for(int i=0; i<n; i++)
        {

            scanf("%s%d%d",st,&a,&b);
            if(!map[a][b])
            {
                N[num].v=a;
                N[num++].c=b;
            }
            map[a][b]++;

        }
        memset(f,0,sizeof(f));
        int k,sum;
        for(int i=0; i<num; i++)
        {
            k=1;
            sum=0;
            while(sum<map[N[i].v][N[i].c])

            {
                for(int j=m; j>=k*N[i].c; j--)
                    f[j]=max(f[j],f[j-k*N[i].c]+k*N[i].v);
                sum+=k;
                k*=2;
                if(k+sum>map[N[i].v][N[i].c])
                    k=map[N[i].v][N[i].c]-sum;
            }
        }
        printf("%d\n",f[m]);
    }
    return 0;
}

提示:要注意输入个数 否则 会超时
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值