C - ACboy needs your help HDU - 1712

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit? 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. 
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. 
N = 0 and M = 0 ends the input. 

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain. 

Sample Input

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

Sample Output

3
4
6

 

题意:第i门课花j天收益为a[i][j],问n门课m天最大收益多少。

思路:

状态 dp[i][j]:前i门课花j天最大收益。

对于第i门课,有以下两种情况:

1.不选  dp[i][j]=dp[i-1][j]

2. 选    dp[i][j]=max{dp[i-1][j-k]} 1<=k<=j

#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;

const int N=105;
const int M=105;
int a[N][M],f[N][M];
int main()
{
    int n,m;
    while(cin>>n>>m&&n&&m){
       memset(f,0,sizeof(f));
       for(int i=1; i<=n; i++){
         for(int j=1; j<=m; j++){
            cin>>a[i][j];
         }
       }
       for(int i=1; i<=n; i++){
           for(int j=1; j<=m; j++){
              f[i][j]=f[i-1][j];//不选
              for(int k=1; k<=j; k++){
                 f[i][j]=max(f[i][j],f[i-1][j-k]+a[i][k]);
              }
           }
       }
       cout<<f[n][m]<<endl;
    }
    return 0;

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值