poj 1306 combinations

Combinations
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8745 Accepted: 4064

Description

Computing the exact number of ways that N things can be taken M at a time can be a great challenge when N and/or M become very large. Challenges are the stuff of contests. Therefore, you are to make just such a computation given the following:  
GIVEN: 5 <= N <= 100; 5 <= M <= 100; M <= N  
Compute the EXACT value of: C = N! / (N-M)!M!  
You may assume that the final value of C will fit in a 32-bit Pascal LongInt or a C long. For the record, the exact value of 100! is:  
93,326,215,443,944,152,681,699,238,856,266,700,490,715,968,264,381,621, 468,592,963,895,217,599,993,229,915,608,941,463,976,156,518,286,253, 697,920,827,223,758,251,185,210,916,864,000,000,000,000,000,000,000,000  

Input

The input to this program will be one or more lines each containing zero or more leading spaces, a value for N, one or more spaces, and a value for M. The last line of the input file will contain a dummy N, M pair with both values equal to zero. Your program should terminate when this line is read.

Output

The output from this program should be in the form:  
N things taken M at a time is C exactly.  

Sample Input

100  6
20  5
18  6
0  0

Sample Output

100 things taken 6 at a time is 1192052400 exactly.
20 things taken 5 at a time is 15504 exactly.
18 things taken 6 at a time is 18564 exactly.
 
这题本是水题,最近学习dp,拿来练习。
写这题折腾了挺久的,就是因为数据溢出了,我明明long long 了,但是却没有过,第二天过了。。。可能是编译器的问题吧。
 
/********************************/
/*Problem: poj 1306             */
/*User:   Morezy                */
/Memory: 800k                  	*/
/*Time:  0Ms	                */
/Language: G++                    */
/*************************************/

 

#include <iostream>
#define min(x,y) x<y?x:y;

using namespace std;
long long a[150][150];

long long  f(int n,int m)
{
    a[n][n] = 1;
    a[n][0] = 1;
    if (a[n][m])
    {
        return a[n][m];
    }
    a[n][m] = f(n-1,m)+ f(n-1,m-1);
    return a[n][m];
}
int main ()
{
   int n,m,w;
   while (cin >> n >> m && (n || m))
   {
    w = min(m,n-m);
    for (int i = 1; i <= n; i++)
    {
        for (int j = 0; j <= w; j++)
        {
          a[i][j] = 0;
        }
    }
    cout << n << " things taken "<< m << " at a time is "<< f(n,w) << " exactly."<< endl;
   }
   return 0;
}
 
下面一种是普通方法,参考了一下别人的代码
Problem: 1306
User: Morezy
Memory: 664K
Time: 16MS
Language: G++
Result: Accepted

#include<iostream>
using namespace std;

int min(int a, int b){
    return a < b ? a : b;
}

int main(){
    int n, m, t, i, j;
    while(cin >> n >> m && (n || m)){
        t = min(m, n - m);
        __int64 ans = 1;
        for(i = n, j = 2; i >= n - t + 1; i --){
            ans *= i;
            while(ans % j == 0 && j <= t )   // 关键点。
                ans /= j ++;
        }
        cout << n << " things taken "<< m << " at a time is "<< ans << " exactly."<< endl;
    }
    return 0;
}
 
这样一比较,动态规划的优势就非常地明显。
 
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值