POJ 2349 - Arctic Network (最小生成树 Prim)

23 篇文章 0 订阅
12 篇文章 0 订阅

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

题意:

      有n个基站,其中有s个基站能通过卫星联系,剩下的需要用无线电联系,因为无线电覆盖面积越大费用就越大,所以要求无线电之间最小的距离D,使基站可以直接或间接的联系。

思路:

      因为要求最小的距离,所以就让卫星联系的两个基站之间的距离尽可能的大,s个基站通过卫星联系,所以产生了s-1条边。求出最小生成树,把dis数组从大到小排序,dis[s]就是第s大的边,就是除了卫星通信外最大的权值,就是要求的了。

     因为输入t之后没有t--,RE了n次,最后才发现哭晕在厕所了。

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#define inf 99999999

double map[600][600],dis[600];
int book[600];
int main()
{
	int t,m,n,i,j,k,a,b,count;
	double min,u;
	int x[600],y[600];
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			count=u=0;
			memset(book,0,sizeof(book));
			memset(dis,0,sizeof(dis));
			scanf("%d%d",&m,&n);
			for(i=1;i<=n;i++)
				scanf("%d%d",&x[i],&y[i]);
			for(i=1;i<=n;i++)
				for(j=1;j<=n;j++)
				{
					if(i==j)
						map[i][j]=0;
					else
						map[i][j]=inf;
				}
			for(i=1;i<n;i++)
				for(j=i+1;j<=n;j++)
				{
					map[i][j]=map[j][i]=(double)sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
				}
			for(i=1;i<=n;i++)
				dis[i]=map[1][i];
			book[1]=1;
			count++;
			while(count<n)
			{
				min=inf;
				for(i=1;i<=n;i++)
				{
					if(book[i]==0&&dis[i]<min)
					{
						min=dis[i];
						j=i;
					}
				}
				book[j]=1;
				count++;
				for(k=1;k<=n;k++)
				{
					if(book[k]==0&&dis[k]>map[j][k])
						dis[k]=map[j][k];
				}
			}
			for(i=1;i<n;i++)
				for(j=i+1;j<=n;j++)
				{
					if(dis[i]<dis[j])
					{
						u=dis[i];
						dis[i]=dis[j];
						dis[j]=u;
					}
				}
			printf("%.2f\n",dis[m]);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值