POJ 2253 - Frogger(Dijkstra最短路)

23 篇文章 0 订阅
13 篇文章 0 订阅

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:

      青蛙 a 要去找青蛙 b ,但是他不想一步跳太远,他想绕其他石头,求他绕道其他石头到b的位置需要跳的最远为多少。

思路:

      用Dijkstra求最短路,把距离存到map数组里比较。

    因为.f  写成了 .lf WA了n次,都没找出来原因,想锤死自己 :)。

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
int inf = 99999999;
int x[220],y[220],book[220];
double e[220][220],dis[220];
double max(double x,double y)
{
	if(x>=y)
		return x;
	else
		return y;
}
int main()
{
	int n,i,j,k,u,flag=0,min;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
			break;
		flag++;
		memset(book,0,sizeof(book));
		memset(e,0,sizeof(e));
		memset(dis,0,sizeof(dis));
		for(i=1;i<=n;i++)
			scanf("%d%d",&x[i],&y[i]);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(i==j)
					e[i][j]=0;
				else
					e[i][j]=inf;
			}
		for(i=1;i<=n;i++)
			for(j=i+1;j<=n;j++)
			{
				e[i][j]=e[j][i]=(double)sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
			}
		for(i=1;i<=n;i++)
			book[i]=0;
		for(i=1;i<=n;i++)
			dis[i]=e[1][i];
		for(i=1;i<=n-1;i++)
		{
			min=inf;
			for(j=1;j<=n;j++)
			{
				if(book[j]==0&&dis[j]<min)
				{
					min=dis[j];
					u=j;
				}
			}
			book[u]=1;
			for(j=1;j<=n;j++)
			{
				
				if(dis[j]>max(dis[u],e[u][j]))
					dis[j]=max(dis[u],e[u][j]);
			}
		}
		printf("Scenario #%d\n",flag);
		printf("Frog Distance = %.3f\n\n",dis[2]);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值