HDU 3829 - Cat VS Dog(最大独立集)

49 篇文章 0 订阅
7 篇文章 0 订阅

The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

Input

The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)

Output

For each case, output a single integer: the maximum number of happy children.

Sample Input

1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1

Sample Output

1
3


        
  

Hint

Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.
        
题意:

       动物园里有猫和狗,不同的小朋友喜欢不同的小动物,把他们不喜欢的小动物拿走他们就会开心,求最多能使多少小朋友开心。

思路:

       把喜好相反的小朋友存入二分图中,再求最大独立集。

       最大独立集 = 顶点数 - 最大匹配数

代码:

#include<stdio.h>
#include<string.h>
int map[1010][1010],book[1010],match[1010];
int n,m,p;
int dfs(int u)
{
	int i;
	for(i=1;i<=p;i++)
	{
		if(book[i]==0&&map[u][i]==1)
		{
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=u; 
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,sum,s;
	char a[510][20],b[510][20];
	while(scanf("%d%d%d",&n,&m,&p)!=EOF)
	{
		memset(map,0,sizeof(map));
		memset(match,0,sizeof(match));
		s=sum=0;
		getchar();
		for(i=1;i<=p;i++)
			scanf("%s%s",a[i],b[i]);
			
		for(i=1;i<=p;i++)
        	for(j=1;j<=p;j++)
	       {
	           if(strcmp(a[i],b[j])==0||strcmp(a[j],b[i])==0)
	           map[i][j]=1;
	       }
		for(i=1;i<=p;i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
				sum++;
		}
		printf("%d\n",p-sum/2); 
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值