ALL in ALL

/*All in All
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in
a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the
original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded
in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that
the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.
The length of s and t will no more than 100000.
Output
For each test case output “Yes”, if s is a subsequence of t,otherwise output “No”.
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No*/
题意:给出两个字符串,比较第二个字符串是否包含第一个字符串,可以不连续,但顺序不能混乱。
思路:两个字符串进行逐字比较,如果是s[i]=t[j],记住字符串t的位置,以后在进行比较时从该位置后进行比较,保证顺序不混乱,当字符串s比较结束后,输出“Yes”,如果s[i]不在字符串t中,则直接输出“No”。

#include<stdio.h>
#include<string.h>
int main()
{
    char s[100010],t[100010];
    while(~scanf("%s%s",s,t))
    {
        long len1=strlen(s);
        long len2=strlen(t);
        int i,j,k=0;
        for(i=0;i<len1;i++)
        {
            for(j=k;j<len2;j++)
            {
                if(s[i]==t[j])
                {
                    k=j+1;          
                    break;
                }
            }
            if(j==len2&&i<len1)
            {
                printf("No\n");
                break;
            }
        }
        if(i==len1)
            printf("Yes\n");
    }
    return 0;
}
#include<stdio.h>
#include<string.h>
int main()
{
    char s[100010],t[100010];
    while(~scanf("%s%s",s,t))
    {
        long len1=strlen(s);
        long len2=strlen(t);    
        int i,j;
        i=0;j=0;
        while(1)
        {   
            if(i==len1)
            {
                printf("Yes\n");
                break;
            }
            else if(j==len2&&i<len1)
            {
                printf("No\n");
                break;
            }
            else if(s[i]==t[j])
            {
                i++;
                j++;
            }
            else
               j++;
        }
        memset(s,'\0',sizeof(s));  
        memset(t,'\0',sizeof(t));       
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值