PAT甲级1002. A + B for Polynomials(25)

1002. A + B for Polynomials(25)
This time, you are supposed to find A + B where A and B are two polynomials.
Input
Each input file contains one test case.Each case occupies 2 lines, and each line contains the information of a polynomial : K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi(i = 1, 2, ..., K) are the exponents and coefficients, respectively.It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <= 1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input.Notice that there must be NO extra space at the end of each line.Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

翻译:

A+B多项式

这次,你要算出A+B,A和B是2个多项式

输入:

每个输入文件包含一个实例。每个实例占2行,每行包含一个多项式的信息:K N1 aN1 N2 aN2 ... NK aNK,K是多项式中非零项的个数。Ni and aNi(i = 1, 2, ..., K)分别是指数和系数。给出的范围是 1 <= K <= 10,0 <= NK < ... < N2 < N1 <= 1000.

输出:

对每一个实例,你应该在一行里用和输入相同的格式输出A+B的和。注意,每行的末尾不能有多余的空格。请保留一位小数。

输入样例:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

输出样例:

3 2 1.5 1 2.9 0 3.2

分析:创建一个数组代表A+B的和多项式,p[i]表示指数为i的多项式的系数为p[i],每输入一项就把该项的系数加到对应的p[i]里去。比如输入 2  1.5 那么p[2]+=1.5。最后统计一下非零项的系数,然后从后向前输出非零项就ok了

#include<iostream>
#include<string>
using namespace std;
int main()
{
	float p[1001] = { 0 };               //多项式数组,p[i]=ceo,表示指数为i的项系数为ceo
	int K, i;							//要输入K组信息
	int ex;								//指数
	float coe;							//系数
	
	cin >> K;                          //多项式A
	for (i = 0; i < K; i++)
	{
		cin >> ex >> coe;               //输入
		p[ex] += coe;                   //把coe存入对应项的系数
	}

	cin >> K;                          //多项式B
	for (i = 0; i < K; i++)
	{
		cin >> ex >> coe;             //输入
		p[ex] += coe;                 //把coe存入对应项的系数

	}

	int count = 0;                    //count表示非零项的个数
	for (i = 0; i <= 1000; i++)       //统计非零项的个数
		if (p[i])
			count++;

	cout << count;                    //输出非零项个数

	for (i = 1000; i >= 0; i--)
		if (p[i])                     //如果是非零项
		{
			cout <<" "<< i << " ";    //输出指数
			cout.setf(ios::fixed);    //保留一位小数输出系数
			cout.precision(1);
			cout << p[i];
			count--;
		}
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值