AYIT2017暑假集训第二周周三赛 B - Out of Hay POJ - 2395

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.
Input
* Line 1: Two space-separated integers, N and M. 

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.
Output
* Line 1: A single integer that is the length of the longest road required to be traversed.
Sample Input
3 3
1 2 23
2 3 1000
1 3 43
Sample Output
43
Hint
OUTPUT DETAILS: 

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.
 
 
题目的大概意思就是说给你几条边,让你组成一个最小生成树,挑出最小生成树里面的最大边
模板题目,我对自己没写出来也和无语
#include<stdio.h>
#include<algorithm>
using namespace std;
struct note//存储顶点和边
{
    int x,y;
    long long int z;//题目说长度很长,所以用long long int
}l[50000];
int n,m;
int f[3000],sum,count1;//f存储根节点
long long int cmp(note a,note b)
{
    return a.z<b.z;
}
int gf(int v)//找根函数,确定自己和谁在一块
{
    if(f[v]==v)
        return v;
    else
    {
        f[v]=gf(f[v]);
        return f[v];
    }
}
int mer(int v,int u)//合并两子集合的函数
{
    int t1,t2;
    t1=gf(v);
    t2=gf(u);
    if(t1!=t2)//判断两个节点是不是在同一个集合里面
    {
        f[t2]=t1;//进行合并
        return 1;
    }
    return 0;
}
int main()
{
    int i;
    while(~scanf("%d%d",&n,&m))
    {
        for(i=0;i<m;i++)
            scanf("%d%d%lld",&l[i].x,&l[i].y,&l[i].z);
        for(i=1;i<=n;i++)
            f[i]=i;//对存储根的数组进行初始化
        long long int k=0;
        count1=0;
        sort(l,l+m,cmp);//对其边长进行排序
        //for(i=0;i<m;i++)
           // printf("%d %d %lld\n",l[i].x,l[i].y,l[i].z);
        for(i=0;i<m;i++)//开始对每一条边进行遍历
        {
            if(mer(l[i].x,l[i].y))//如果不在同一个集合里面,经用他
            {
                count1++;
                k=max(k,l[i].z);//找出最小生成树里面那条最大的边
            }
            if(count1==n-1)break;
        }
        printf("%lld\n",k);
    }
}

1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 、4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。、可私 6信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 、4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。、可 6私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 、4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。、可私 6信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值