AYIT2017暑假集训第二周周三赛 D - Meteor Shower POJ - 3669

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (XiYi) (0 ≤ X≤ 300; 0 ≤ Y≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: Xi,Yi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input
4
0 0 2
2 1 2
1 1 2
0 3 5
Sample Output

5

题目大概意思就是给你坐标和时间,在时间过后那个地点会遭到轰炸,轰炸过后那个点和他四周的四个点都不能走了,问能否找到一个安全点。如果能的话输出步数,不能输出-1.


#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int vis[330][330];//存储地图
int next[5][2]= {{0,0},{1,0},{0,1},{-1,0},{0,-1}};//在主函数中因为要把自身的坐标也变化所以加了0,0.
struct note
{
    int x,y,t;
} l[30000];//模拟队列
int bfs()
{
    if(vis[0][0]==0) return -1;//若第一个点时间直接为0,说明直接死了;
    else if(vis[0][0]==-1) return 0;//若第一个点为-1,说明他一个就是安全点
    int head=1,tail=2;
    l[head].x=0;//起始点坐标
    l[head].y=0;
    l[head].t=0;//把时间置为0
    while(head<tail)
    {
        for(int i=1; i<5; i++)
        {
            int tx=l[head].x+next[i][0];
            int ty=l[head].y+next[i][1];//向四个方向进行搜索
            if(tx<0 || ty<0) continue;
            if(vis[tx][ty]==-1)  return  (l[head].t+1);//若找到了vis为-1得点,说明找到了安全点
            if((l[head].t+1)>=vis[tx][ty]) continue;//如果时间大于vis点的值,说明该点之前被轰炸过不能走
            vis[tx][ty]=0;//走过之后把点标记为0.
            l[tail].x=tx;
            l[tail].y=ty;
            l[tail].t=l[head].t+1;//时间加一
            tail++;
        }
        head++;
    }
    return -1;
}

int main()
{
    int m,k,t,x,y,x1,y1;
    scanf("%d",&m);
    memset(vis,-1,sizeof(vis));
    for(int j=0;j<m;j++)
    {
        scanf("%d%d%d",&x,&y,&t);
        for(int i=0; i<=4; i++)
        {
            x1=x+next[i][0];//输入点坐标进行计算,因为被轰炸过所以不能走
            y1=y+next[i][1];
            if(x1<0 || y1<0) continue;
            if(vis[x1][y1]==-1)//假如是安全点把他vis值改变
                vis[x1][y1]=t;
            else
                vis[x1][y1]=min(vis[x1][y1],t);//如果有更小的进行更新,限制路径
        }
    }
    printf("%d\n",bfs());
    return 0;
}

深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值