NYoj410how many ones?(同余定理)

how many ones?

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 2
描述
Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?
输入
Each line contains a number n.
输出
Output the number of digits.
样例输入
3 
7 
9901
样例输出
3
6
12
#include<stdio.h>//AC代码
int main()
{
	int n;
	while(~scanf("%d",&n)){
		int i,sum=0;
		for( i=1;;i++){
			sum=(sum*10+1)%n;
			if(!sum)
			break;
		}
		printf("%d\n",i);
	}
return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值