Codeforces 803 B. Distances to Zero (模拟

B. Distances to Zero

Description

You are given the array of integer numbers a0, a1, …, an - 1. For each element find the distance to the nearest zero (to the element which equals to zero). There is at least one zero element in the given array.

Input

The first line contains integer n (1 ≤ n ≤ 2·105) — length of the array a. The second line contains integer elements of the array separated by single spaces ( - 109 ≤ ai ≤ 109).

Output

Print the sequence d0, d1, …, dn - 1, where di is the difference of indices between i and nearest j such that aj = 0. It is possible that i = j.

Sample Input

9
2 1 0 3 0 0 3 2 4
5
0 1 2 3 4

Sample Output

2 1 0 1 0 0 1 2 3 
0 1 2 3 4 

题意

给一组数,让找这组数中每个数离0的最小距离

题解:

模拟一发, 标记0的位置 不停的比较位置大小就可以了

AC代码

#include <bits/stdc++.h>
using namespace std;
vector<int>v;
int main()
{
    int n;
    int x;
    scanf("%d",&n);
    for(int i = 0;i < n; i++) {
        scanf("%d",&x);
        if(x==0) v.push_back(i);
    }
    int k = 0;
    for(int i = 0;i < n; i++) {
        int  ans = abs(i-v[k]);
        if(k>0) {
            if(ans > 0) ans = min(ans,abs(i-v[k-1]));  // 比较和上一个零点哪个离零点小 
        }
        if(ans == 0) k++;
        if(i)
            printf(" %d",ans);
        else printf("%d",ans);
    }
    printf("\n");
return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值