Codeforces #245 (Div. 2)C. Xor-tree(DFS&&贪心

C. Xor-tree

Description

ahub is very proud of his recent discovery, propagating trees. Right now, he invented a new tree, called xor-tree. After this new revolutionary discovery, he invented a game for kids which uses xor-trees.

The game is played on a tree having n nodes, numbered from 1 to n. Each node i has an initial value initi, which is either 0 or 1. The root of the tree is node 1.

One can perform several (possibly, zero) operations on the tree during the game. The only available type of operation is to pick a node x. Right after someone has picked node x, the value of node x flips, the values of sons of x remain the same, the values of sons of sons of x flips, the values of sons of sons of sons of x remain the same and so on.

The goal of the game is to get each node i to have value goali, which can also be only 0 or 1. You need to reach the goal of the game by using minimum number of operations.

Input

The first line contains an integer n (1 ≤ n ≤ 105). Each of the next n - 1 lines contains two integers ui and vi (1 ≤ ui, vi ≤ n; ui ≠ vi) meaning there is an edge between nodes ui and vi.

The next line contains n integer numbers, the i-th of them corresponds to initi (initi is either 0 or 1). The following line also contains n integer numbers, the i-th number corresponds to goali (goali is either 0 or 1).

Output

In the first line output an integer number cnt, representing the minimal number of operations you perform. Each of the next cnt lines should contain an integer xi, representing that you pick a node xi.

Sample Input

10
2 1
3 1
4 2
5 1
6 2
7 5
8 6
9 8
10 5
1 0 1 1 0 1 0 1 0 1
1 0 1 0 0 1 1 1 0 1

Sample Output

2
4
7

题意

给出一棵树,有n个节点,根为1,每个节点的值不是0就是1,每次可以翻转一个节点,翻转后,当前节点值翻转,其儿子节点不变,孙子追随翻转,依次类推,求最少翻转次数,使得每个节点的值与目标结果相同。

题解:

搜根下面的点 不同就操作改变 (不影响父节点的更新)
值得注意的是给的节点关系并未声明方向 所以是无向TAT

AC代码

#include <bits/stdc++.h>
using namespace std;

#define LL long long
#define CLR(a,b) memset(a,(b),sizeof(a))

const int N = 1e5+10;
int s[N], t[N];
int vis[N];
vector<int> v[N];
int n;
int ans;
void dfs(int x,int y,int z)
{
    if(vis[x]) return;
    vis[x] = 1;
    if(s[x]^y != t[x]) {
        vis[x] = 2;
        ans ++;
        y = !y;
    }
    for(int i = 0;i <v[x].size(); i++) {
        dfs(v[x][i],z,y);
    }
}

int main()
{
    cin>>n;
    for(int i = 0;i <= n; i++) v[i].clear();
    int x, y;
    for(int i = 1;i < n; i++) {
        cin>>x>>y;
        v[x].push_back(y);
        v[y].push_back(x);
    }   
    for(int i = 1;i <= n; i++) cin>>s[i];
    for(int i = 1;i <= n; i++) cin>>t[i];
    CLR(vis,0);
    ans = 0;
    dfs(1,0,0);
    cout<<ans<<endl;
    for(int i = 1;i <= n; i++) {
        if(vis[i] == 2) cout<<i<<endl;
    }
return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值