HDU 1671 Phone List ( Trie树

Phone List

题目描述

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

输入

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

输出

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

样例

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES

题意

内存给的有点小了emmm

AC代码

#include <bits/stdc++.h>
using namespace std;

#define LL long long
#define CLR(a,b) memset(a,(b),sizeof(a))
#define lson  st<<1
#define rson st<<1|1

const int MAXN = 1e5+100;
int trie[MAXN][12];  // trie[i][j] = k// 表示i的节点的第j个孩子是编号为k的节点
int tot;
void sert(string s, int root) {
    for(int i = 0; i < s.length(); i++) {
        int x = s[i]-'0';
        if(trie[root][x]==0)
            trie[root][x] = ++tot;
        root = trie[root][x];

    }
    //vis[root] = true;
}

bool find(string s, int root) {
    for(int i = 0; i < s.length(); i++) {
        int x = s[i]-'0';
        if(trie[root][x]==0)
            return false;
        root = trie[root][x];
    }
    return true;
    //return vis[root];
}
string ss[10010];
int main() {
    int T;
    cin >> T;
    while(T--) {
        tot = 1;
        CLR(trie,0);
        bool flag = false;
        int n;
        cin >> n;
        for(int i = 0; i < n; i++) {
            cin >> ss[i];
        }
        sort(ss,ss+n);
        for(int i = n-1; i >=0; i--) {
            if(find(ss[i],1)) {
                flag = true; break;
            }
            sert(ss[i],1);
        }
        if(flag) cout << "NO\n";
        else cout << "YES\n";
        for(int i = 0; i < n; i++) ss[i].clear();
    }
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值