题目链接:点击打开链接
Smallest Difference
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 10469 | Accepted: 2862 |
Description
Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0.
For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.
For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.
Input
The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.
Output
For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.
Sample Input
1 0 1 2 4 6 7
Sample Output
28
大意:给你 0~9 10个数中的任意几个数,要求用这几个数组成两个数所得到的两数差的最优解。
思路:STL 里面的全排列 next_permutation() ,枚举每一种排列,注意要去除前导为 0 的情况
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
int num,a[22];
void work()
{
while(a[0]==0)
next_permutation(a,a+num);
int ans=INF;
do
{
if(a[num/2])
{
int x=a[0],y=a[num/2];
for(int i=1;i<num/2;i++)
x=x*10+a[i];
for(int i=num/2+1;i<num;i++)
y=y*10+a[i];
ans=min(ans,abs(x-y));
}
}while(next_permutation(a,a+num));
printf("%d\n",ans);
}
int main()
{
int t;
scanf("%d",&t);
getchar();
while(t--)
{
char ch;
num=0;
while(scanf("%c",&ch),ch!='\n')
{
if(ch>='0'&&ch<='9')
a[num++]=ch-'0';
}
if(num==1)
printf("%d\n",a[0]);
else if(num==2)
printf("%d\n",a[1]-a[0]);
else
work();
}
return 0;
}