poj-1716【贪心】

题目链接:点击打开链接

Integer Intervals
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14497 Accepted: 6157

Description

An integer interval [a,b], a < b, is a set of all consecutive integers beginning with a and ending with b. 
Write a program that: finds the minimal number of elements in a set containing at least two different integers from each interval.

Input

The first line of the input contains the number of intervals n, 1 <= n <= 10000. Each of the following n lines contains two integers a, b separated by a single space, 0 <= a < b <= 10000. They are the beginning and the end of an interval.

Output

Output the minimal number of elements in a set containing at least two different integers from each interval.

Sample Input

4
3 6
2 4
0 2
4 7

Sample Output

4

大意:

给出数轴上的n个区间,每个区间都是连续的int区间。

现在要在数轴上任意取一堆元素,构成一个元素集合V

要求每个区间和元素集合V的交集至少有两个不同的元素

求集合V最小的元素个数。


#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n;
struct node
{
	int a,b;
}s[10010];
bool cmp(node x,node y)
{
	return x.b<y.b;
}
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;i++)
			scanf("%d%d",&s[i].a,&s[i].b);
		sort(s,s+n,cmp);
		int ans=2; // 点集初始数目 
		int r=s[0].b,l=r-1; // 集合内初始元素 
		for(int i=1;i<n;i++)
		{
			if(s[i].a>l&&s[i].a<=r) // 集合内仅有最新一个元素属于该区间 
			{
				ans++;
				l=r,r=s[i].b;
			}
			else if(s[i].a>r) // 集合与该区间无交集 
			{
				ans+=2;
				r=s[i].b,l=r-1;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值