HDU1084:What Is Your Grade?


Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!  
Come on!
 

Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 

Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 

Sample Input
  
  
4 5 06:30:17 4 07:31:27 4 08:12:12 4 05:23:13 1 5 06:30:17 -1
 

Sample Output
  
  
100 90 90 95 100
 


 

一道结构体排序题

 

#include <stdio.h>
#include <algorithm>
using namespace std;

struct STU
{
    int num,h,m,s,score,no;
    int step;
} stu[105];

int cmp(STU x,STU y)
{
    if(x.num>y.num)
        return 1;
    if(x.num == y.num)
    {
        if(x.h<y.h)
            return 1;
        else if(x.h == y.h)
        {
            if(x.m<y.m)
                return 1;
            else if(x.m == y.m)
            {
                if(x.s<y.s)
                    return 1;
                return 0;
            }
            return 0;
        }
        return 0;
    }
    return 0;
}

int cmp2(STU x,STU y)
{
    return x.no<y.no;
}

int main()
{
    int n;
    while(~scanf("%d",&n) && n>0)
    {
        int i;
        int l3,l4,l2,l1;
        l1 = l2 = l3 = l4 = 0;
        for(i = 0; i<n; i++)
        {
            scanf("%d %d:%d:%d",&stu[i].num,&stu[i].h,&stu[i].m,&stu[i].s);
            stu[i].no = i;
            if(stu[i].num == 4)//统计各个题数出现的次数
                l4++;
            else if(stu[i].num == 3)
                l3++;
            else if(stu[i].num == 2)
                l2++;
            else if(stu[i].num == 1)
                l1++;
        }
        sort(stu,stu+n,cmp);
        int s1,s2,s3,s4;
        s1 = s2 = s3 = s4 = 1;
        for(i = 0; i<n; i++)//统计作对相同题数的人所排的位置
        {
            if(stu[i].num == 4)
                stu[i].step = s4++;
            else if(stu[i].num == 3)
                stu[i].step = s3++;
            else if(stu[i].num == 2)
                stu[i].step = s2++;
            else if(stu[i].num == 1)
                stu[i].step = s1++;
        }
        sort(stu,stu+n,cmp2);
        for(i = 0; i<n; i++)
        {
            if(stu[i].num == 5)
                printf("100\n");
            else if(stu[i].num == 4)
            {
                if(stu[i].step <= l4/2)//位置小于一半的人分数较高
                    printf("95\n");
                else
                    printf("90\n");
            }
            else if(stu[i].num == 3)
            {
                if(stu[i].step <= l3/2)
                    printf("85\n");
                else
                    printf("80\n");
            }
            else if(stu[i].num == 2)
            {
                if(stu[i].step <= l2/2)
                    printf("75\n");
                else
                    printf("70\n");
            }
            else if(stu[i].num == 1)
            {
                if(stu[i].step <= l1/2)
                    printf("65\n");
                else
                    printf("60\n");
            }
            else if(stu[i].num == 0)
                printf("50\n");
        }
        printf("\n");
    }

    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值