POJ2406 Power Strings

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 37293 Accepted: 15409

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题目传送门:POJ2406 Power Strings

又是KMP nex数组的应用题。这道题和POJ 1961 Peroid很像。(POJ1961题解链接→POJ 1961 题解   POJ1961 Peroid题目链接)一下搞两道- -。这道题是输入一串字符,我们来找它的循环周期,比如输入ababab,循环节是ab,循环了3次,输出3。再比如aaaa,循环节是a,循环了4次,输出4。要注意的是如果没有循环下来,比如abca、abcdab这样的情况,输出1。

解题方法:关于循环节的问题,我们知道这样一个结论:长度为len的字符串,循环节的长度是len-next[len],我们把它定为s。那么如果len%s==0,也就是字符串长度能整除循环节长度,就说明这个字符串是完全循环的,也就是类似abcabc、ababab的情况。那么在本题中,如果字符串是完全循环完毕的,我们只要输出len/s就ok了。如果len%s!=0,说明字符串不是完全循环完毕的,比如abcdab、abcabce这样,我们输出1就好了。下面是AC代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define N 1000005
char a[N];
int nextt[N];
int len;

void getNext()
{
    int i,j;
    i=0;
    j=-1;
    nextt[i]=j;
    while(i<len)
    {
        if(j==-1 || a[i]==a[j])
        {
            i++;
            j++;
            nextt[i]=j;
        }
        else
            j=nextt[j];
    }
    return ;
}

int main()
{
    int m,ans;
    while(~scanf("%s",a))
    {
        ans=1;
        if(a[0]=='.')
            break;
        len=strlen(a);
        memset(nextt,0,sizeof(nextt));
        getNext();
        m=len-nextt[len];
        if(len%m==0)
            ans=len/m;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值