Teacher Bo

Teacher Bo

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 384    Accepted Submission(s): 219


Problem Description
Teacher BoBo is a geography teacher in the school.One day in his class,he marked N points in the map,the i -th point is at (Xi,Yi) .He wonders,whether there is a tetrad (A,B,C,D)(A<B,C<D,ACorBD) such that the manhattan distance between A and B is equal to the manhattan distance between C and D.

If there exists such tetrad,print "YES",else print "NO".
 

Input
First line, an integer T . There are T test cases. (T50)

In each test case,the first line contains two intergers, N, M, means the number of points and the range of the coordinates. (N,M105) .

Next N lines, the i -th line shows the coordinate of the i -th point. (Xi,Yi)(0Xi,YiM) .
 

Output
T lines, each line is "YES" or "NO".
 

Sample Input
  
  
2 3 10 1 1 2 2 3 3 4 10 8 8 2 3 3 3 4 4
Sample Output
     
     
YES NO
曼哈顿距离:是|x2-x1|+|y2-y1|
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[100001],b[100001];
int s[200000]= {0};
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(s,0,sizeof(s));
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&a[i],&b[i]);
        }
        if(n>m)
        {
            printf("YES\n");
        }
        else
        {
            int f=0;
            int p=0;
            int h=0;
            for(int i=0; i<n; i++)
            {
                for(int j=i+1; j<n; j++)
                {
                        h++;
                        int t,k,ni;
                        t=(a[j]-a[i]);
                        k=(b[j]-b[i]);
                        if(t<0)
                        {
                            t=-t;
                        }
                        if(k<0)
                        {
                            k=-k;
                        }
                        ni=k+t;
                        s[ni]++;
                        if(s[ni]>=2)//有两个相等的就可以输出yes了
                        {
                            f=1;
                            break;
                        }
                    }
                if(f==1)
                {
                    break;
                }
            }
                if(f==1)
                    printf("YES\n");
                else
                    printf("NO\n");
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值