杭电5762之Teacher Bo

Problem Description
Teacher BoBo is a geography teacher in the school.One day in his class,he marked N points in the map,the i -th point is at (Xi,Yi) .He wonders,whether there is a tetrad (A,B,C,D)(A<B,C<D,ACorBD) such that the manhattan distance between A and B is equal to the manhattan distance between C and D.

If there exists such tetrad,print "YES",else print "NO".
 

Input
First line, an integer T . There are T test cases. (T50)

In each test case,the first line contains two intergers, N, M, means the number of points and the range of the coordinates. (N,M105) .

Next N lines, the i -th line shows the coordinate of the i -th point. (Xi,Yi)(0Xi,YiM) .
 

Output
T lines, each line is "YES" or "NO".
 

Sample Input
  
  
2 3 10 1 1 2 2 3 3 4 10 8 8 2 3 3 3 4 4
 

Sample Output
  
  
YES

NO

分析:求是否存在四点(a,b,c,d),使得两点(a,b)与另外两点(c,d)间的曼哈顿距离相等

AC代码如下:

#include <iostream> 
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <string>
#include <map>
using namespace std;

#define mem(a) memset(a, 0, sizeof(a))
const int maxn = 1e5+100;
int b[maxn], q[2*maxn+100],a[maxn];


int main() {
    int t,i,n,m,j,f,res;
    scanf("%d",&t);
    while (t --) {
        mem(q);
        scanf("%d%d",&n,&m);    
        for (i = 1; i<=n; i++) 
        {
            scanf("%d%d",&a[i], &b[i]);    
        }
        if (n>1000)    printf("YES\n");//n等于1000时,有1000*999/2种点的组合(距离),如果有相同的距离组合,输出YES,若全部相同,
					//m最大值为1e5(距离为整数,故最多有2*1e5种距离),1000*999/2>1e5,
        else                            //由抽屉原理可知肯定有两个距离相等,故也应输出YES,1000仍可缩小,进一步减少运行时间,
					//此处节省运行时间,否则后面的代码枚举必定超时
        {
            res = 0;
            for (i = 1; i<=n; i++) 
            {
                for (j = i+1; j<=n; j++) 
                {
                    f = abs(a[j]-a[i])+abs(b[j]-b[i]);
                    q[f] ++ ;//保存距离不同的组合
                    if (q[f] > 1) //大于1,则存在相等距离
                    {
                        res = 1;
                        goto end;//退出双层循环,至 下面的 end: 位置
                    }
                }
            }
end:
            if (res == 0)    printf("NO\n");
            else    printf("YES\n");
        }
        
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值