F - Teacher Bo(鸽巢定理)

F - Teacher Bo

Teacher BoBo is a geography teacher in the school.One day in his class,he marked N points in the map,the i-th point is at (Xi,Yi).He wonders,whether there is a tetrad (A,B,C,D)(A<B,C<D,A≠CorB≠D) such that the manhattan distance between A and B is equal to the manhattan distance between C and D.

If there exists such tetrad,print “YES”,else print “NO”.
Input
First line, an integer T. There are T test cases.(T≤50)

In each test case,the first line contains two intergers, N, M, means the number of points and the range of the coordinates.(N,M≤105).

Next N lines, the i-th line shows the coordinate of the i-th point.(Xi,Yi)(0≤Xi,Yi≤M).
Output
T lines, each line is “YES” or “NO”.
Sample Input
2
3 10
1 1
2 2
3 3
4 10
8 8
2 3
3 3
4 4
Sample Output
YES
NO

用鸽巢定理防超时,因为有点得范围,在m范围内如果想没有重复的曼哈顿距离,最多可以有m个点,因此超过就一定有重复的。
曼哈顿距离即两点坐标abs(x1-x2)+(y1-y2).
ac代码:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
long long t,n,m,a[1000005],cnt,x[1000005],y[1000005];
int main(){
	cin>>t;
	while(t--){
		memset(a,0,sizeof(a));
		cin>>n>>m;
		for(int i=0;i<n;i++){
			cin>>x[i]>>y[i];
		}
		cnt=0;
		int flag=0;
		for(int i=0;i<n;i++){
			for(int j=i+1;j<n;j++){
				cnt++;
				if(cnt>(2*m)){
					flag=1;
					break;
				}
				int sum=abs(x[i]-x[j])+abs(y[i]-y[j]);
				//cout<<"sum:"<<sum<<endl;
				//cout<<a[sum]<<endl;
				if(a[sum]==0){
					a[sum]++;
				}
				else{
					flag=1;
					break;
				}
			}
		}
		if(flag) cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值